CURSO TÉCNICO DE INFORMATICA

Forum criado para os retirada de duvidas e integração entre os alunos do curso técnico do ETEIT
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Conectar-se  

Compartilhe | 
 

 Exercicio extra classe

Ir em baixo 
AutorMensagem
Jobuns

avatar

Número de Mensagens : 9
Poder de fogo : 11
Reputação : 0
Data de inscrição : 13/03/2009
Idade : 28

MensagemAssunto: Exercicio extra classe   Qua Mar 18, 2009 12:36 pm

Ai galera, a resolução daquele exercício extra classe da aula do Jerffeson, a resposta mais valida que eu poderia afirma seria essa:

Algoritmo "Calculadora"; //Nome do programa
Var
vN1, vN2 : Real; //N = número
vCalc : Real; //Calc = Calculadora
vOp : Caracter; // Op = Operação

Inicio

Imprima ("Insira um número: "); //Campo de texto
Leia(vN1);
Se (vN1 != NULO) entao //Comando para não dar bug no programa
Imprima ("Insira um número: ");
Leia(vN2);
senao
Imprima ("Favor, insira um número válido: ");
Leia(vN1);
Fim-se; //Fim do comando Se
Se (vN2 != NULO) entao // Começo Se
Imprima ("Tipo da operação: ");
Escolha vOp // Mutipla escola para a operação
Caso 1: Imprima ("+");
Caso 2: Imprima ("-");
Caso 3: Imprima ("*");
Caso 4: Imprima ("/");
Caso 5: Imprima ("Pot");
Fim-escolha; //Fim da mutipla escolha
senao
Imprima ("Favor, insira um número válido: ");
Leia (vN2);
Fim-se; //Fim do Se
Se (vOp = "+") entao //Comando se para as operações
vCalc <- vN1 + vN2;
senao
Se (vOp = "-") entao
vCalc <- vN1 - vN2;
senao
Se (vOp = "*") entao
vCalc <- vN1 * vN2;
senao
Se (vOp = "/") entao
vCalc <- vN1 / vN2;
senao
Se (vOp = "Pot") entao
vCalc <- pot (vN1 , vN2);
Fim-se;
Fim-se;
Fim-se;
Fim-se;
Fim-se;
Imprima ("O resultado da sua conta é: ", vCalc);

Fim.


Quem não tiver entendido, manda um e-mail para mim com a duvida
Jonas_ui@hotmail.com beleza?
Valeu galerinha!!!


Última edição por Jobuns em Qua Mar 18, 2009 6:17 pm, editado 2 vez(es)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Admin
avatar

Número de Mensagens : 31
Poder de fogo : 334
Reputação : 0
Data de inscrição : 12/03/2009
Idade : 32

MensagemAssunto: Re: Exercicio extra classe   Qua Mar 18, 2009 1:35 pm

boua 06 mando bem

_________________
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cti-eteit.forumeiros.com
Jobuns

avatar

Número de Mensagens : 9
Poder de fogo : 11
Reputação : 0
Data de inscrição : 13/03/2009
Idade : 28

MensagemAssunto: Re: Exercicio extra classe   Qua Mar 18, 2009 6:14 pm

Tinha um erro ai no programa eu fui verificar la no curso quando cheguei!!


Foi mal
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Ezra'eiL(Ramon)

avatar

Número de Mensagens : 16
Poder de fogo : 12
Reputação : 0
Data de inscrição : 12/03/2009
Idade : 27

MensagemAssunto: Re: Exercicio extra classe   Qua Mar 18, 2009 10:58 pm

ele pediw potencia?

se colocar

Caso 1: Imprima ("+","-","*","/",''pot''); tá errado?


Fim-se;
Fim-se;
Fim-se;
Fim-se;
Fim-se; pq 5 Fim-se;?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Jobuns

avatar

Número de Mensagens : 9
Poder de fogo : 11
Reputação : 0
Data de inscrição : 13/03/2009
Idade : 28

MensagemAssunto: Simples   Qua Mar 18, 2009 11:26 pm

"Caso 1: Imprima ("+","-","*","/",''pot''); tá errado?"

Sim, esta errado, porque esse caso, significa múltipla escolha ou seja, cada imprimi la no comando, é uma alternativa, resumindo, se coloca daquela forma citada, tudo aquilo ali será uma alternativa só.

"Fim-se;
Fim-se;
Fim-se;
Fim-se;
Fim-se; pq 5 Fim-se;?"

Simples, são 5 comandos fim-se, ou seja, todo se, tem que termina com um comando fim-se, porque na lógica da programação, a estrutura seria assim:

Se (vOp = "+") entao //Comando se para as operações
vCalc <- vN1 + vN2;
senao
Se (vOp = "-") entao
vCalc <- vN1 - vN2;
senao
Se (vOp = "*") entao
vCalc <- vN1 * vN2;
senao
Se (vOp = "/") entao
vCalc <- vN1 / vN2;
senao
Se (vOp = "Pot") entao
vCalc <- pot (vN1 , vN2);
Fim-se;
Fim-se;
Fim-se;
Fim-se;
Fim-se;


Entendeu? cada se que colocar, é uma estrada de comandos, e para finalizar, tem que ter o fim-se, é como se fosse o parênteses (a(b(c))) cada abertura de parênteses tem que ter o fim

Deu pra pegar??
Se não pode falar que explico de outro modo!!!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Ezra'eiL(Ramon)

avatar

Número de Mensagens : 16
Poder de fogo : 12
Reputação : 0
Data de inscrição : 12/03/2009
Idade : 27

MensagemAssunto: Re: Exercicio extra classe   Qua Mar 18, 2009 11:37 pm

opa, se é assim então éh =D


vlwsss
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Jobuns

avatar

Número de Mensagens : 9
Poder de fogo : 11
Reputação : 0
Data de inscrição : 13/03/2009
Idade : 28

MensagemAssunto: Conhecimento   Qua Mar 18, 2009 11:41 pm

Pelo menos, o que eu sei de programação, e o Jerffeson me falo, que inclusive na aula eu perguntei sobre o imprima daquela forma, ele disse que é errado.
E sobre o se, ele já tinha explicado, cada Se tem que ter um fim-se.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Admin
avatar

Número de Mensagens : 31
Poder de fogo : 334
Reputação : 0
Data de inscrição : 12/03/2009
Idade : 32

MensagemAssunto: Re: Exercicio extra classe   Qui Mar 19, 2009 9:14 am

ALgoritmo "VCalculo";
Var
Vn1,vn2,vop:Real;


inicio

Imprima("Entre com o 1º número");
Leia(vn1);
se(vn1 <> nulo) entao
imprima(Forneça o 1º numero);
Imprima("entre com a operação * / + -");
Leia(vop);
se(vop<> Nulo) entao
Imprima("Forneça corretamente a operação");
Imprima("Entre com o 2º número");
Leia(vn2);
se(vn2 <>nulo) entao
Imprima("forneça o 2º número);
se(Vop="+")entao
vop<-vn1+vn2;
se(vop="-")entao
vop<-vn1-vn2;
se(vop="/") eantao
vop<-vn1/vn2;
senao(vop=*) entao
vop<-vn1*vn2

fim-se;
fim-se;
fim-se;
fim-se;
Imprima("Resutado total : ",vop);
fim.

_________________


Última edição por Admin em Qui Mar 19, 2009 2:22 pm, editado 1 vez(es)
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cti-eteit.forumeiros.com
Jobuns

avatar

Número de Mensagens : 9
Poder de fogo : 11
Reputação : 0
Data de inscrição : 13/03/2009
Idade : 28

MensagemAssunto: Opa   Qui Mar 19, 2009 10:23 am

Aquela parte do Se (vOp <> "/ + - *")
o programa vai interpretar assim
se no vOp não for = / + - * no mesmo campo, o comando se vai ser ativado.
O Jerffeson me falo que não pode ser assim, perguntei ele na aula inclusive até para simplificar o exercício, mas diz ele que é errado
Entendeu?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Ezra'eiL(Ramon)

avatar

Número de Mensagens : 16
Poder de fogo : 12
Reputação : 0
Data de inscrição : 12/03/2009
Idade : 27

MensagemAssunto: Re: Exercicio extra classe   Qui Mar 19, 2009 9:02 pm

vc não respondeu.. ele pediu potencia?


Obs: perguntei isso no horario de aula.. =P




num era melhor perguntar pessoalmente?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Admin
avatar

Número de Mensagens : 31
Poder de fogo : 334
Reputação : 0
Data de inscrição : 12/03/2009
Idade : 32

MensagemAssunto: Re: Exercicio extra classe   Sex Mar 20, 2009 11:41 am

naum pedi potencia naum isso ai foi so um charme a mais rsrs

_________________
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cti-eteit.forumeiros.com
Daher

avatar

Número de Mensagens : 2
Poder de fogo : 2
Reputação : 0
Data de inscrição : 17/03/2009
Idade : 27

MensagemAssunto: Re: Exercicio extra classe   Sex Mar 20, 2009 4:15 pm

Não ramon... ele nao pediu potencia cheers o Jobas quis aparecer/brinks
ta bao isso ae hein >D
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Exercicio extra classe   

Voltar ao Topo Ir em baixo
 
Exercicio extra classe
Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» exercicio ajuda
» SIMETRIA EXERCICIO COM ÂNGULOS
» exercicio determinante 4X4
» Exercicio trigonometria
» Mediana em dados agrupados em classe

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
CURSO TÉCNICO DE INFORMATICA :: DISCIPLINAS :: METODOS DE DESENVOLVIMENTO-
Ir para: